Download Voltage Modular

Voltage Modular Version History

macOs:

Version: 2.2.5

Date: 4/15/2021

Requirements: macOS 10.9 or above, 64-bit required. Compatible with M1 processors (via Rosetta 2). Quad-core computer with 8GB of RAM recommended. NOTE: Internet connection required for product activation.

Download for macOS

Windows:

Version: 2.2.5

Date: 4/15/2021

Requirements: Windows 7 or above, 64-bit required. Quad-core computer with 8GB of RAM recommended. NOTE: Internet connection required for product activation.

Download for Windows