Voltage Modular Support

Need a point in the right direction?

FAQ Documentation Contact Us Version History

Known issues:

Voltage Modular does not currently work with Reason on Windows, see our forums for more details.

Available Platforms:

Mac: OS X 10.9 or above, 64-bit required. Quad-core computer with 8GB of RAM recommended.

Windows: Windows 7 or above, 64-bit required. Quad-core computer with 8GB of RAM recommended.

Do you have an account?

There are new and exciting things being developed for Voltage Modular and we would’t want you to miss the news. Sign up to stay informed about new releases and updates!

Create An Account

Log Into the Cherry Audio Store

Demo of Voltage Modular

Sounds from Voltage Modular