Download

Version 1.0.7, Released February 2nd, 2021

Polymode Synthesizer Version History

macOS

macOS 10.9.5 or above, 64-bit required. Quad-core computer with 8GB of RAM recommended. NOTE: Internet connection required for product activation.

Windows

Windows 7 or above, 64-bit required. Quad-core computer with 8GB of RAM recommended. NOTE: Internet connection required for product activation.

Once you've downloaded and installed the software, you'll be asked to login to your Cherry Audio Store account. If you do not have an account on our store, you can create one here:

Create an Account